Follow

Video not working

We use Wistia to host our videos, and we've noticed a few problems come up for some of our students.

1. Video not loading

Sometimes Wistia has trouble loading the videos over their CDN.To see if this is the problem, try visiting this page: http://wistia.com/plp/free-video-hosting If this video is having the same problems, then you may need to wait a few hours while their servers recover.

2. Audio and Video out of sync

We've seen this issue most commonly with Firefox browsers. Try viewing the video using a different browser (Chrome or Safari) and see if the problem persists. Since Firefox recently ceased using Flash, Wistia has changed all their videos to use HTML5 on Firefox browsers, so this may have resolved the issue.

3. Other Problems

If you're seeing another issue, please let us know right away. Please send us a message, and include the following information:

a) which video you are trying to view (page URL is perfect)

b) your User Agent (see http://www.whatsmybrowser.org/ for more info)

c) where you are located in the world

d) your internet connection speed (see http://www.speedtest.net for how to find this)

From Wistia, we've also gotten some tips for troubleshooting video issues:

  • In general, one of the first things we suggest is clearing the browser cache and resetting the router (it's a preliminary step we like to rule out immediately).
  • Does the problem persist in other browsers? 
  • Similar to the above, I'd also recommend testing in different devices or networks. This can be helpful in seeing how widespread or narrow the problem is.
  • The minimum viable connection speed to stream Wistia video reliably is about 768 kilobits per second (equal to .768 megabits per second), but we recommend a connection speed of at least 5 megabits per second for an optimal experience with HD playback. 
Powered by Zendesk